Reports of failing payments

Incident Report for Tilroy

Resolved

This incident has been resolved.
Posted Sep 06, 2025 - 23:39 CEST

Monitoring

The situation normalized.
Posted Sep 06, 2025 - 17:28 CEST

Investigating

We receive a higher number of error reports in finalizing a sale. This is under investigation.
Posted Sep 06, 2025 - 17:26 CEST
This incident affected: Point Of Sale.