Errors when creating pdf documents

Incident Report for Tilroy

Postmortem

Incident Report: PDF generating Issues

On 19/03/2026 , our platform experienced a service interruption , which prevented the creation of PDF invoices. We understand the significant impact this has on your daily operations, and we sincerely apologize for the inconvenience this caused.

What happened?

To generate invoices within our software, we use a background service that controls a digital browser (similar to Chrome) to format and prepare your documents as PDFs. In the past, we had to manually configure and update this browser to ensure it stayed compatible with our specific systems.

What went wrong?

Yesterday, an automatic update occurred within the browser software’s external environment.
This new version unexpectedly became incompatible with our PDF module.

The issue was particularly persistent because our systems are designed to automatically fetch the latest browser version upon startup. As a result, even rolling back to a previous version of our PDF software did not resolve the issue, as the system continued to install the new, incompatible browser version. This explains why it took longer than usual to fully restore the service.

How was this resolved?

Our engineering team has changed how the PDF module is structured to ensure long-term stability:

  • Integrated Linking: We have rebuilt the system so that the PDF module now directly manages its own specific browser version. They are now treated as a single, unified package.
  • Guaranteed Compatibility: This change ensures that the module and the browser can never "fall out of sync." If one is updated, the other is automatically and safely updated alongside it.
  • Stabler Infrastructure: We have migrated to a new technical foundation specifically optimized for these tasks, increasing the overall reliability of our document generation.

Conclusion

The outage was caused by an external update that no longer aligned with our manual configuration. By changing the underlying technology and giving the system full control over its own dependencies, we have eliminated this risk. This ensures that a similar compatibility issue cannot occur in the future.

Thank you for your patience and for your continued trust in our platform.

Posted Mar 20, 2026 - 16:08 CET

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 13:49 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 11:48 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 19, 2026 - 10:28 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2026 - 09:12 CET

Investigating

We noticed that there are errors when creating pdf documents like invoices and quotations, we are investigating the issue.
Posted Mar 19, 2026 - 08:49 CET
This incident affected: Point Of Sale and Data management and reporting.