Postmortem info added - Tilroy is not available.

Incident Report for Tilroy

Postmortem

Between 08:15 and 08:21 on 19/06/2025, the Tilroy platform experienced a short disruption that temporarily blocked many sales transactions. Although the rest of the system remained available stores and webshops were unable to complete sales during this window.

This interruption was caused by a backend issue in our messaging infrastructure. In that five-minute period, a significant number of the components responsible for this messaging process (called "nodes") began to fail simultaneously.

Our automated infrastructure immediately started replacing the failed nodes, which restored the system within minutes. However, during the recovery process, sales operations were temporarily halted because the platform couldn’t complete the essential communication steps needed to start or finalize a sale.

We know every minute matters in retail. Once our internal analysis is complete, we will share more details about the cause and the improvements being implemented in next releasenotes.

Posted Jun 19, 2025 - 11:31 CEST

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 08:26 CEST

Update

We have identified the problem, it should be solved in 15 minutes.
Posted Jun 19, 2025 - 08:20 CEST

Identified

At the moment Tilroy is not available.
Use offline mode to continue.
We are investigating and will send updates when more information is available.
Posted Jun 19, 2025 - 08:17 CEST
This incident affected: Point Of Sale and Data management and reporting.